getting Access denied error

PGNP install, uninstall, and setup.

getting Access denied error

Postby LK4772 » Fri Sep 02, 2011 11:59 am

Hello. I found this post and went through the steps. However I am still getting the following error:

Msg 7399, Level 16, State 1, Line 2
The OLE DB provider "PGNP" for linked server "PGNP_SAMPLES" reported an error. Access denied.
Msg 7350, Level 16, State 2, Line 2
Cannot get the column information from OLE DB provider "PGNP" for linked server "PGNP_SAMPLES".


I saw in a few other posts to double check the AllowInProcess, and I can't seem to find that setting when looking at the properties for the linked server, but I did run the EXEC master.dbo.sp_MSset_oledb_prop N'PGNP.1', N'AllowInProcess', 1 statement several times. There was also another post saying to modify the pg_hba.conf to make sure the postgres server is allowing access. I have updated the file with the following line:

local all all md5


I have the following setup: Windows 7 box, both Postgres and SQL Server databases on same Windows 7 box, Postgres 8.4, SQL Server 2008 R2
LK4772
 
Posts: 2
Joined: Fri Sep 02, 2011 11:47 am

Re: getting Access denied error

Postby Moderator » Sat Sep 03, 2011 11:40 am

Please check that you can open connection to Postgres. For this create an empty test.udl file on your desktop, double-click on it. In the Data Link Properties dialog enter catalog name, user and password. Click Test Connection button and see if connection was successful. If not able to connect, please troubleshoot the Postgres server.

If connecting to localhost, you would not need to modify pg_hba.conf.

After you tested connection using udl file, proceed to the linked server. Please read Developer's Manual on linked servers: http://pgoledb.com/index.php?option=com ... wnload&cid[0]=3&Itemid=68.
User avatar
Moderator
Site Admin
 
Posts: 297
Joined: Wed Oct 29, 2008 11:27 pm


Return to Install and Setup

Who is online

Users browsing this forum: No registered users and 1 guest