Disabling PGNP optimizer

General PGNP discussions.

Disabling PGNP optimizer

Postby barakp » Wed Nov 13, 2013 12:56 am

Hi,
I'm using PGNP to connect to a postgresql DB. In the DB's log I see the following error:
ERROR: relation "pgnp_optimizer" does not exist at character 49
STATEMENT: SELECT OPTIMIZER_ID, HASHTYPE, HASH, FINAL FROM PGNP_OPTIMIZER WHERE ENABLED = 'Y'

I would like to disable the PGNP optimizer as I'm connecting with a read only user to the database.
Please advise how to do so.

Thanks,
Barak
barakp
 
Posts: 1
Joined: Wed Nov 13, 2013 12:51 am

Re: Disabling PGNP optimizer

Postby Moderator » Mon Nov 18, 2013 10:29 am

We added new connection string parameter OPTIMIZER=ON/OFF in build 1.4.0.3200. This is an optional parameter, and the default value is OFF (optimizer is not enabled).

Users who previously used the Optimizer must add the parameter OPTIMIZER=ON to the Extended Properties of the connection string.
User avatar
Moderator
Site Admin
 
Posts: 310
Joined: Wed Oct 29, 2008 11:27 pm


Return to Miscellaneous

Who is online

Users browsing this forum: No registered users and 1 guest

cron