Connection Problem

Using PGNP with MS SQL Server, Data Transformation Services (DTS), SQL Server Integration Services (SSIS), Linked Servers, Snapshot and Transactional Replication and more.

Connection Problem

Postby siraj098 » Wed Nov 17, 2010 5:36 pm

Hi I have just downloaded the PNG OLEDB driver for evaluation. I am having problem in making the connection through SSIS connection manager. Any advice will be appritaited.

Regards
Siraj
siraj098
 
Posts: 2
Joined: Wed Nov 17, 2010 4:05 pm

Re: Connection Problem

Postby Moderator » Wed Nov 17, 2010 8:03 pm

Make sure that the following controls are filled with correct information:
"Server or file name" - computer name with PostgreSQL server (or localhost);
"User name" - PostgreSQL user name;
"Password" - the password.

Click on arrow in "Initial Catalog" combo. The list of databases should be displayed. If the list is empty, then either there is a firewall preventing the connection, or password is not correct.
User avatar
Moderator
Site Admin
 
Posts: 293
Joined: Wed Oct 29, 2008 11:27 pm

Re: Connection Problem

Postby rhino155 » Thu Jan 27, 2011 3:15 pm

Hi,

I'm trying to connect from sql server 2008 SSIS over the WAN to a postgresql using pgnp data source. I'm receiving the following error:

"test connection failed because of an error in initializing provider. Value does not fall within the expected range."

Here are my setting in the SSIS Connection Mgr:

Provider: .Net Providers for OleDb\PostgreSQL Native Provider
Server or File Name: <Target Server IP Address>
Location: <"">
User Name: <user name>
Password : <pswd>

Should the port be included in the ServerName?
I noticed an earlier post suggested appending the database name to the server name? What would be the syntax for that? "ServerName:DatabaseName"? "ServerName/DatabaseName"?

Any help would be appreciated.

Thanks
rhino155
 
Posts: 2
Joined: Thu Jan 27, 2011 2:57 pm

Re: Connection Problem

Postby rhino155 » Thu Jan 27, 2011 3:18 pm

Never mind, I figured it out. Actually I clicked on the DataLinks button and filled out the same connection info and it worked.
rhino155
 
Posts: 2
Joined: Thu Jan 27, 2011 2:57 pm

Re: Connection Problem

Postby erin.nichols » Tue Jul 15, 2014 5:25 am

I'm receiving the same error rhino155 was while I'm trying to connect from my machine to a remote machine. I tried the solution that worked for them and it does not for me. Are there any other potential fixes?
erin.nichols
 
Posts: 1
Joined: Tue Jul 15, 2014 5:24 am

Re: Connection Problem

Postby Moderator » Wed Jul 16, 2014 9:44 am

Could you check connectivity from the computer using a UDL file? If DDL connect test worked, please check if all connection string parameters were populated correctly. Let us know if it still did not work. Thank you!
User avatar
Moderator
Site Admin
 
Posts: 293
Joined: Wed Oct 29, 2008 11:27 pm


Return to SQL Server/DTS/SSIS/Linked servers/Replication

Who is online

Users browsing this forum: No registered users and 1 guest

cron