Way to not use a transaction?

Using PGNP with MS SQL Server, Data Transformation Services (DTS), SQL Server Integration Services (SSIS), Linked Servers, Snapshot and Transactional Replication and more.

Way to not use a transaction?

Postby mmetzger » Wed Dec 08, 2010 9:00 am

Hi -

We're transferring a large amount of data but seeing the server eat a huge amount of memory during the transfer. Looking in the profiler, it appears to issue a transaction at the beginning of the transfer. Is there an easy way to disable this and simply execute the command directly?

Thanks!
mmetzger
 
Posts: 6
Joined: Fri Nov 05, 2010 10:00 am

Re: Way to not use a transaction?

Postby Moderator » Wed Dec 08, 2010 9:04 pm

Are you transferring data into the Postgres DB? If that's the case, are you using connection string parameter BULK_METHOD=COPY?
User avatar
Moderator
Site Admin
 
Posts: 306
Joined: Wed Oct 29, 2008 11:27 pm

Re: Way to not use a transaction?

Postby mmetzger » Wed Dec 08, 2010 9:24 pm

Yes, it's transferring data into postgres. I had tried using the COPY option, but unfortunately postgres does not appear to support the use of BYTEA fields in COPY options (even COPY BINARY) as all my tests came out blank.
mmetzger
 
Posts: 6
Joined: Fri Nov 05, 2010 10:00 am

Re: Way to not use a transaction?

Postby Moderator » Sun Dec 19, 2010 12:08 pm

Could you send us tables schema and any additional information to help us reproduce the issue with large memory utilization?

We are working on bytea and COPY issue.

Thank you
User avatar
Moderator
Site Admin
 
Posts: 306
Joined: Wed Oct 29, 2008 11:27 pm


Return to SQL Server/DTS/SSIS/Linked servers/Replication

Who is online

Users browsing this forum: No registered users and 1 guest

cron