Subqueries with multiple columns fail on

Report PGNP bugs.

Subqueries with multiple columns fail on

Postby Raphael » Sun Sep 05, 2010 7:50 am

I've had multiple queries that used subqueries with multiple columns. As in:

WHERE (uppercol1, uppercol2) IN
(SELECT col1, col2 FROM subtable)

When writing them on provider, they worked all right.
With the latest provider ( they all fail to return data. No error message is given. Rolling back to the older version restores ability to run these queries.

I've been able to work around this by altering my queries but it would be great to have the option to use multiple columns back. If not possible, having a meaningful error message would be fantastic.
Posts: 3
Joined: Fri Dec 04, 2009 2:12 pm

Re: Subqueries with multiple columns fail on

Postby Moderator » Mon Sep 06, 2010 10:43 pm

Thank you for letting us know about the defect. We have fixed it in build 2184. Please send request to support at pgoledb dot com if you need installation module with the fix.
User avatar
Site Admin
Posts: 362
Joined: Wed Oct 29, 2008 11:27 pm

Return to Report Bugs

Who is online

Users browsing this forum: No registered users and 1 guest