OLE DB connection tests OK, but fails to get data

Report PGNP bugs.

OLE DB connection tests OK, but fails to get data

Postby Verhasselt » Tue Nov 29, 2011 5:19 pm

I'm running the trial v1.4.0.3012 on Windows XP, tunneling via SSH (putty) to PostgreSQL v8.3.11

The "test connection" feature reports: Connection test succeeded.

Using Excel 2007, the Data Connection Wizard appears and I can see my database's tables.
(the "select database" drop-down shows all the databases on the provider's server)
I select my database name from the dropdown
I select a table
I hit "next"
I'm at the "Save Data Connection File and Finish"
I hit [Finish]
Excel's "Import Data" dialog box comes up - I accept the default settings (Table, into existing worksheet)
I hit [OK]
The PGNP Trial Version Evaluation License agreement pops up.
I agree.
Microsoft Office Excel dialog box comes up:
Cannot open DB connection
The PGNP Trial Version Evaluation License agreement pops up. (again)
I agree.

Same problem happens when I attempt to connect via ESRI's "ArcGIS" product.
Except with ArcGIS, the ArcGIS program "crashes hard" and a "send error report" dialog box comes up.

This has happened on every machine I've tried, including Win XP and System 7

Is this a bug, or is there something I'm missing?

Thanks!
Verhasselt
 
Posts: 1
Joined: Tue Nov 29, 2011 5:03 pm

Re: OLE DB connection tests OK, but fails to get data

Postby Moderator » Wed Nov 30, 2011 9:34 pm

It looks like a bug. This scenario had been working in the past. We are trying to reproduce the issue, and will update you shortly.
Thank you!
User avatar
Moderator
Site Admin
 
Posts: 302
Joined: Wed Oct 29, 2008 11:27 pm

Re: OLE DB connection tests OK, but fails to get data

Postby Moderator » Wed Nov 30, 2011 9:59 pm

Have you checked "Save password in file" check box in the "Save Data Connection File and Finish" dialog?

It seems that this scenario worked in our latest tests. Would you send screenshots or any additional info on the issue to Support at pgoledb dot com.
User avatar
Moderator
Site Admin
 
Posts: 302
Joined: Wed Oct 29, 2008 11:27 pm


Return to Report Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron