SSIS Lookup issues

More
10 years 4 months ago #10735 by Moderator
Replied by Moderator on topic Re: SSIS Lookup issues
I'm sorry for delay, but we had not been able to find solution yet. I will try to double check status of the issue, and will update the thread.

In the meantime please change hasSideEffects=true, as a workaround.

Please Log in or Create an account to join the conversation.

  • Visitor
  • Visitor
10 years 1 month ago #10946 by
Replied by on topic Re: SSIS Lookup issues
I have the same issue. Lookup connection to PostgreSQL causes the same issue mentioned above. For now I transfer the lookup table to cache and set the connection to cache table.

I set the property hasSideEffect="true" (I did it textually since it is read only in the Lookup component editor) on Lookup Input Column, but it did not help, same problem occurs.

Please Log in or Create an account to join the conversation.

  • Visitor
  • Visitor
10 years 1 month ago #10953 by
Replied by on topic Re: SSIS Lookup issues
Hi,

We have a somewhat different problem. We use a MsSQL DB as source and PostGres as destination. Before inserting, I want to make sure the rows do not exist via a lookup. When no rows are in the destination, the flow runs fine, but when there are already rows in the destination, it throws errors at pre-processing:

[Lookup P2S [805]] Error: SSIS Error Code DTS_E_OLEDBERROR. An OLE DB error has occurred. Error code: 0x80040E21.
[Lookup P2S [805]] Error: OLE DB error occurred while populating internal cache. Check SQLCommand and SqlCommandParam properties.
[Lookup P2S [805]] Information: The component "Lookup P2S" (805) failed to process the rows in the cache. The processing time was 0.125 second(s).
[SSIS.Pipeline] Error: component "Lookup P2S" (805) failed the pre-execute phase and returned error code 0xC020824E.

I changed the hasSideEffect="true", but that did not work.

I also changed to "no cache", but that returns, while processing:

[Lookup P2S [805]] Error: OLE DB error occurred while fetching parameterized row. Check SQLCommand and SqlCommandParam properties.

Please Log in or Create an account to join the conversation.

More
10 years 3 weeks ago #10986 by Moderator
Replied by Moderator on topic Re: SSIS Lookup issues
Hi,
could you please send a test package that reproduces the issue to support at pgoledb.com?

Thank you!

Please Log in or Create an account to join the conversation.

Time to create page: 0.146 seconds
Powered by Kunena Forum